プログラミングメカブログ

Adults cling to the past, Children want to escape to the future

プログラミングメカブログ

Adults cling to the past, Children want to escape to the future

10月

05

PHP5.3からPHP5.4にバージョンアップ

  • POSTED BY 小谷松 丈樹 IN 調査
  • No Comments

PHP5.4

新しいフレームワークを入れようと調査した所、PHP5.4系が必要である事が分かりました。

PHPのバージョンが5.3系。アカンかった。
という事でバージョンを5.4系に切り替えましょう。

手順

必要な手順は、以下の通り。

  1. リポジトリを確認
  2. PHP5.3をアンインストール
  3. PHP5.4をインストール

リポジトリを確認

PHP5.4のリポジトリを確認します。

amzn-updatesというリポジトリで公開されているようですね。
このリポジトリを指定してアップデートをかけましょう。
ちなみにこのamzn-updatesリポジトリで、他に入れるプラグインも調べておきます。

--disablerepo=base,extras,amzn-main
–disablerepoオプションを指定する事で、デフォルトで選択されるリポジトリに含まれる更新情報を省けるようです。

PHP5.3をアンインストール

アンインストールが完了したか確認します

何も該当せず、出力されないのでアンインストールは完了です。

PHP5.4をインストール

怒られた。httpd24-toolsが競合起こしているみたいですね。
httpdも消して入れなおす必要があるようです。

httpdを消して、競合は解決されるかな?
もっぺん叩いてみます。

きた!

PHP5.4きた!これで勝つる!

一応apacheを起動して表示確認。
php54

大丈夫そうですね。
リポジトリ指定とか勉強になりました。

Tags : |

コメントを残す

Please type the characters of this captcha image in the input box

Please type the characters of this captcha image in the input box